Friday, August 10, 2007

HP-UX: kthread: table is full

If you ever encounter this error in dmesg or syslog.log
[root abc12]home/root # dmesg | tail
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
kthread: table is full
[root abc12]home/root #
[root abc12]home/root # cat /var/adm/syslog/syslog.log | grep kthread
Aug 9 21:37:12 abc12 vmunix: kthread: table is full
Aug 9 21:37:14 abc12 vmunix: kthread: table is full
Aug 10 14:07:18 abc12 vmunix: kthread: table is full
Aug 10 14:07:20 abc12 vmunix: kthread: table is full
[root abc12]home/root #


Then what you need to do is increase the maxusers kernel param in /stand/system

Steps:
1. Log in as root and edit/add maxusers 200 (16-way systems) or maxusers 400 (large 64-way systems i.e. SuperDome) in /stand/system

2. Run these commands:
mk_kernel -v -o /stand/vmunix
kmupdate
reboot -r


3. For God sake don't copy and paste the above commands, as the last command is reboot! Make sure you're safe/authorized to do a reboot before hitting the last command, or else, you're SuperDOOM.

To monitor the processes utilization, issue this command:
[root abc12]home/root # sar -v 1 5

HP-UX abc12 B.11.11 U 9000/800 08/10/07

17:58:07 text-sz ov proc-sz ov inod-sz ov file-sz ov
17:58:08 N/A N/A 172/664 0 1087/7360 0 1209/12018 0
17:58:09 N/A N/A 172/664 0 1087/7360 0 1209/12018 0
17:58:10 N/A N/A 172/664 0 1087/7360 0 1207/12018 0
17:58:11 N/A N/A 172/664 0 1087/7360 0 1207/12018 0
17:58:12 N/A N/A 172/664 0 1087/7360 0 1207/12018 0

[root abc12]home/root #


Look under proc-sz column, the 172/664 values represent the current number of processes (172) and the maximum number of processes (664).

To view the current value of maxusers:
[root abc12]home/root # cat /stand/system | grep maxusers
maxusers 200
[root abc12]home/root #


or

[root abc12]home/root # kmtune | sed q;kmtune | grep maxusers

Parameter             Current Dyn Planned                    Module     Version
maxusers 200 - 200

[root abc12]home/root #

*2nd option tu nampak cam terrer la sikit

If you wanna choose a less-headache version, use SAM. Don't know how to use SAM? Eat yourself.

No comments: